1

We are facing issue while using "force:createRecord" event in lightning. Its working for Standard object when we are giving entityApiName as "Account" but on the same hand if we are doing it with custom object its not working.

Working:-

 ({
createRecord : function(component, event, helper) {
     var createRecordEvent = $A.get("e.force:createRecord");

    createRecordEvent.setParams({
        "entityApiName": "Account"                  
    });
    createRecordEvent.fire();
}
})

Not Working:-

({
createRecord : function(component, event, helper) {
     var createRecordEvent = $A.get("e.force:createRecord");

    createRecordEvent.setParams({
        "entityApiName": "CustomeObj__c"                        
    });
    createRecordEvent.fire();
}
})
9
  • I recommend you file a case with support on this.
    – crmprogdev
    Sep 10, 2017 at 13:33
  • My custom object createRecord event is working fine in my org. Is your component in one.app container ? ( I know that you said it is working fine for Standard objects but just to recheck. )
    – brahma
    Sep 10, 2017 at 15:19
  • Hello @brahmajitammana, we overrided custom object's new button with our component. As you said its working in your org, can you please tell do you have winter 18? Sep 10, 2017 at 17:29
  • Did this event work for you before the winter18 release? Sep 11, 2017 at 4:05
  • Yes @ItaiShmida, it was working before winter18. Sep 11, 2017 at 6:32

1 Answer 1

1

This is a winter 18 known issue. Check this link for more. Fixed in most of the data centers and release is in progress.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .