0

I cloned one of our existing profiles. With the cloning, the new profile can't cases. It receives the error:

We couldn't find the record you're trying to access. It may have been deleted by another user, or there may have been a system error. Ask your administrator for help.
The case still gets created.

Permissions between the profiles are identical. I am not using Lightning. Is there some other setting I don't know about?

Screenshot:enter image description here

  • There is a lot of missing info. Do you have any custom code involved in the case creation? – Sebastian Kessel Sep 7 '17 at 18:18
  • 1
    Not custom code, no, but it is a certain community page. It's funny because the case object actually gets CREATED, they just can't see the page where it gets created. Now that Im' thinking about it, I wonder if they don't have access to the page where they can view the created case, but they do have permissions do the Case object itself. Do you know where the permissions to that visualforce page would be shown? Adding a screenshot to the case of what the error looks like for them so that you can see what I'm talking about. – Sidereal Sep 7 '17 at 18:22
  • you didn't mention what kind of community this is – glls Sep 7 '17 at 18:45
  • it's a customer community. i actually didn't know there were multiple types of community... – Sidereal Sep 7 '17 at 18:49
0

It turned out to be a Sharing Set on the Customer Community which was causing all the problems..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.