1

I'm trying to setup an environment to use SOSService in my iOS app (https://developer.salesforce.com/docs/atlas.en-us.noversion.service_sdk_ios.meta/service_sdk_ios/ios_sos_quick_start.htm), after set the Podfile with this following code :

source 'https://github.com/CocoaPods/Specs.git'
source 'https://github.com/goinstant/pods-specs-public'

target 'Clickforce' do
    pod 'ServiceSDK'
end

and run my project, I'm receiving this error from X-Code

/Clickforce/Pods/ServiceSDK/Frameworks/ServiceSOS.framework/Headers/SOSNetworkReporter.h:26:9: 

Include of non-modular header inside framework module 'ServiceSOS.SOSNetworkReporter'

This error appears with these two header files : ServiceSOS.h, SOSCameraBasedViewController.h

I'm not able to run my code, after check on another sites, I enabled the configuration to allow non modular includes in framework modules but still doesn't work,

1

I encountered the same error and only way was able to get around this was by manually importing the files myself .

Add the relevant frameworks to the Embedded Binaries section of the General tab for your target app. Be sure to select Copy items if needed when embedding.

Once you’ve embedded the frameworks, you’ll automatically see them appear in the Linked Frameworks and Libraries section as well.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.