7

I am having a problem deploying a new object to either Prod or another Sandbox with Eclipse. The error is very strange, saying "Entity objectname__c not found". It doesn't make sense because I am trying to ADD the new object, so of course it's not going to be able to find it.

I have stripped down the deployment to the bare bones in an attempt to eliminate every possible problem such as validation rules referring to another object which isn't there ; or lookup fields doing the same thing. I am basically just trying to add a custom object with about 4 or 5 text fields on it.

I'm able to deploy the same object by using Change Sets.

I've tried it with several other objects (which were also very basic objects) and have gotten the same error ; but I have been successful with a newly created object. In all cases I was adding a new object, not modifying an already existing one.

Is there possibly a setting or something else with an object which could be causing this?

Has anybody else ever had this happen? If so, what was the problem?

  • Can you clarify... in your source org, you have created the object XML and then compiled (Save to Server)? – greenstork Oct 30 '13 at 18:28
  • Hi @greenstork - I don't really know what you mean by doing a Save to Server. I have just added the custom object and several of its fields to my Eclipse project and attempted to deploy\add it (it would be a new object to the org). I've tried Prod and another Sandbox and have gotten that same error. I have tried with a couple other objects and was unable with them as well - but I was able to deploy a couple others. Is there some kind of setting in a custom object which could cause this ? Like I said earlier, I am able to do deploy every object with Change Sets. – Zoom_v Oct 30 '13 at 18:37
  • Can you confirm there are no other references to this object in other files that are part of the deployment? Is the actual error you see in the console saying that objectname__c.object is the file that is failing? – Michael Welburn Oct 30 '13 at 20:50
  • Try refreshing the metadata in Eclipse for your project. When you do, do you get any errors? It could be there's a problem with the particular area that you're trying to create the custom object in, thus the reason you can do it some times and not at others. Been there & bought the t-shirt too! – crmprogdev Oct 30 '13 at 20:58
  • I'm voting to close this question as off-topic because Abandoned – Eric Feb 28 '17 at 17:43
1

The error means that the entity ObjectName__c is not present in the package.xml file.Try searching it.This might happen if the refresh is not done properly. Either you can try to Refresh the project contents by going to project Properties -> Force.com -> Project Contents -> Add/Remove -> Refresh from Server or if it doesn't work remove the project from eclipse workspace and download it again. This should download the updated package.xml containing the reference to ObjectName__c. Now you can deploy it to whichever server you want.

Hope this helps!!

  • Instead of removing the project and recreate it, he simply he can add manually the new object in the package.xml – Liron C Sep 17 '17 at 14:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.