0

I have profile "Test". When I click Edit and then Save I get the following error message:

enter image description here

This is just a part of a huge error message, which lists all problem objects. The last part of this message is:

enter image description here

If we look at the Banks custom object permissions, the profile doesn't have a Create permission on it. That's what error says too.

enter image description here

What interesting is when I turn on the Modify All Data check box for this profile (all permissions for object automatically checked) and save the profile, it works - the save is done successfully.

enter image description here

But when I Edit the profile again and uncheck the Modify All Data and all Permissions for Bank except Read permission, it is saved successfully too. This is weird enough because previously the error said that Create permission on Bank is required, however it allowed to save the Profile without this permission. Why is it so?

  • You're looking the wrong Modify All Data; check the System Permissions instead. – sfdcfox Aug 23 '17 at 13:06
  • Where can I find those? I don't see System Permissions in the Profile Edit window. – Eduard Aug 23 '17 at 13:36
  • My apologies, in the Classic Profile editor, it's "Administrative Permissions". – sfdcfox Aug 23 '17 at 13:38
  • The thing is I checked Modify All Data in the Administrative Permissions section and saved. After that I unchecked Modify All Data in the Administrative Permissions, unchecked Permissions for Bank (except Read permission) in the Custom Object Permissions and saved... which appeared to be success. What interesting is technically I returned to the state when I was getting that error. It seems that check Modify All Data - save - uncheck Modify All Data and Bank Permissions (i.e. return to previous state) just fixes the problem. But I'd like to know why. – Eduard Aug 23 '17 at 13:52
  • 1
    I'm pretty sure you'll find that Deploy Change Sets has also been disabled as a result of the edit. If not, there's a bug. Only administrators can deploy change sets, because they can change the permissions by using the change set. Whatever it is you're trying to do is likely to end up violating security or causing further errors down the road. – sfdcfox Aug 23 '17 at 13:55
0

I will mark this as the correct answer until @sfdcfox posts his answer.

Deploy Change Sets permission was the problem. I just unchecked it and could save the Profile from the first try.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.