0

I am trying to create a permission set for Knowledge Base. I have a record type and I want to use this object for assigning permissions.

I have created a new permission set and when I try to add Object from Object Settings, I dont see the Article Type or Record Type in the list of objects.

I see "Knowledge" in the object, but there I dont see the options for Read, Edit, Delete etc.

Knowledge Object in Permission Set for Obj Settings

In Profiles, I have permissions for "Knowledge".

I want to know how to add record type or knowledge object for permission set.

Thanks!

0

It seems you are checking wrong object. In permission set there are two Knowledge objects appearing one for Tab Setting and another for Object permission. The screen shot you have attached is for Tab Setting. See the below screenshot: enter image description here

enter image description here

  • I don't see the option for knowledge object with respect to permission setting. I only see it for Tab setting. Can you please guide me as to what I am missing here? – user2598808 Aug 22 '17 at 9:51
  • It seems to be issue with license type in your permission set – salesforce Developer Aug 22 '17 at 9:58
  • Can you please tell me what license you are using in your permission set? – salesforce Developer Aug 22 '17 at 9:59
  • Could be developer license. I am really not sure as I am pretty new to SalesForce. – user2598808 Aug 22 '17 at 10:25
  • open your permission set, there you will see license and change it to salesforce – salesforce Developer Aug 22 '17 at 11:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.