I'm trying to search a record using a global search putting part of the content, but the results show a message: "No matches found".

If I put all the content, the global search show me the record. See the screenshots.

Search with all the content All the content

Search with part of content Part of content

Points to consider:

  • I created a tab to the object;

  • The field is already on the search results page

  • The field is an external ID

  • The FLS is configured

  • 1
    You have a trailing wildcard (222964*) instead of a leading wildcard (*222964). Try moving the wildcard character to the beginning.
    – Adrian Larson
    Commented Aug 21, 2017 at 20:21
  • Hi Adrian, I tried, but doesn't work too. Commented Aug 21, 2017 at 20:23
  • @AdrianLarson that will not work, I have found this undocumented trick '*222964', use of single quote Commented Aug 21, 2017 at 20:54

1 Answer 1


If your intended result to show 10010222964 then you have to search with

'*222964' (Please mind the single quote at the beginning and at the end)

Though I didn't find this trick in the Wildcards and operators for search documentation. But it works for me!

By the way, * asterisk characters best to find items that match zero or more characters at the middle or end of your query. It doesn't work at the beginning.

Currently, you are searching 222964* where system is searching for anything starts with 222964.

  • Hello Santanu, I tried searching using the wildcard like you said, but doesn't work. Thanks for your reply. Commented Aug 21, 2017 at 20:29
  • copy and paste exactly this search phrase: '*0222964' Commented Aug 21, 2017 at 20:45
  • Works like a charm!!! I did not knew that trick Thanks a lot Santanu Commented Aug 21, 2017 at 21:27
  • this is undocumented trick Commented Aug 21, 2017 at 21:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .