20

Is anyone else out there encountering problems with the "Salesforce clients connected apps" package (namespace: sf_com_apps) that is being automatically installed into orgs since the Winter '14 release? This package gets automatically installed if you use "officially supported" connected apps to connect to your org (Salesforce Workbench being one of these apps). Once this package is installed, we keep encountering problems any time we try to save Visualforce pages or components to the server using the Force.com IDE. The following "packagedVersion" reference automatically gets inserted into the meta.xml file for the page or component:

<?xml version="1.0" encoding="UTF-8"?>
<ApexPage xmlns="http://soap.sforce.com/2006/04/metadata">
    <apiVersion>23.0</apiVersion>
    <label>My Visualforce Page</label>
    <packageVersions>
        <majorNumber>1</majorNumber>
        <minorNumber>0</minorNumber>
        <namespace>sf_com_apps</namespace>
    </packageVersions>
</ApexPage>

Any subsequent attempt to save changes to the Visualforce page or component results in the following save error:

Save error: The specified Package Version number does not exist for that Package: sf_com_apps, 1.0

The installed version of this package is actually 1.5. However, changing the minorNumber to 5 and attempting to save doesn't resolve the problem. It simply reverts back to 0 and fails with the same save error upon saving again. The only way to work around the issue is to remove the "packageVersions" element entirely and save. It will save, but it will re-insert the offending "packageVersions" element again, at which point your next save attempt will fail with the same error, unless you remember to remove this element from the meta.xml file first, before saving.

This is wreaking havoc with our Continuous Integration environment, because if a developer commits a meta.xml file containing the "packageVersions" element referencing sf_com_apps, the deployment to the integration org fails with the same error, even though the package is installed in that org too.

  • I face the same issue. Any idea on how to avoid this will really help! – Vignesh Damodharan Oct 28 '13 at 12:54
  • Face the same issue for one of the instance .Hard to do visualforce development due to this – Mohith Shrivastava Oct 28 '13 at 13:20
  • I've got a case open with Salesforce Developer Support on this issue. I will post any useful information, but at this time, I don't have any good workaround for the problem. You can try uninstalling the sf_com_apps package, but it will come back if you use Workbench again. – tlfu Oct 28 '13 at 13:33
4

Well all organisations which have this package installed prevent saving visualforce page. There is no workaround as its metadata is not sync with actual compiled version. Latest information it have is of package 1.0, So it always resets to it.

Uninstall this package if you are not using its any of the following components from winter '14:

  • Dataloader_Partner
  • Forcecom_IDE // No negative effect on Eclipse Force.com IDE after uninstall
  • Forcecom_Migration_Tool
  • Salesforce_Mobile_Dashboards
  • Salesforce_Touch
  • Salesforce_for_Outlook
  • Workbench
  • Dataloader_Bulk

I believe there should not be negative impact on features except the provided features associated with this package because one of my Winter `14 dev org don't have this package and it is functioning normal. I can use Eclipse, Bulk API is working, Dataloader working etc. But new features may be impacted, didn't test those.

Right now the only thing can be do is open the associated meta xml file, remove <package> node and save all by cmd+shift+S / ctrl+shift+S . And this is not a good as direct save

1

As of 11/25/2013, this issue appears to be resolved. If I modify one of my Visualforce pages, the meta.xml file is updated to include a element that references version 1.5 of the sf_com_apps package (the version that is actually installed), and the page is save to the server without error.

1

Try deleting the metadata tag packageVersions sf_com_apps section

0

Save to Server before attempting this, if possible, to avoid data loss.

  1. Right-click project, choose Force.com > Add/Remove Metadata Components.
  2. Click Add/Remove.
  3. Click the Refresh button (two arrows pointing to each other).
  4. Click OK.
  5. Choose to refresh if prompted.
  6. Choose OK.
  7. Choose to refresh if prompted.
  8. Right-click on the project, click "Refresh".

At this point, "Referenced Packages" should gain an arrow and all of your connected apps will appear. You will then be able to save normally without modifying metadata.

  • That doesn't solve the issue. I still get the error after a save. I'm not sure why the meta files are not getting updated in the IDE. However, if you see the meta file in UI, it shows the correct version "1.5". – Vignesh Damodharan Oct 29 '13 at 6:45
  • Odd, It worked in my Dev org. What type of org are you using? What apps do you have? I'm sure there's something simple we're missing. – sfdcfox Oct 29 '13 at 6:56
  • Its too a demo org. The following apps are installed. drive.google.com/file/d/0BzjPmTjXbs87VWFBc1hTemJNM1U/…. – Vignesh Damodharan Oct 29 '13 at 7:10
0

In my case the package has a major a minor and a patch level ie. 10.7.2 I am able to specify in the xml the major (10) and minor (7) but their is no tag to specify the third part of the patch number (2) so the versions don't match and the objects will not deploy.

However I was able to use the built in salesforce outbound and inbound change sets to accomplish the deployment without any complaints about package versions

-2

FYI - I had the same issue. Upgrading to the latest version of the Force.com IDE (v28.0) fixed the problem.

  • I have version 28.0 of the IDE and this problem is still occurring. If you have the sf_com_apps package installed in your org, and you modify and save a .page file, it will insert the <packageVersions> element for sf_com_apps 1.0 into the meta.xml file for the page, and the save will fail with the "specified Package Version number does not exist" error. – tlfu Nov 25 '13 at 12:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.