2

I have a Lightning SPA built with a couple of components embedded in it. When I use lightning out technology to display it on the VF page and it works fine. However, when I use LightningAppBuilder to load the component on the Home page, I'm getting the error where APStage2 is the name of a component within SPA. I don't know what's causing this issue. Anyone run into this same issue?

COMPONENT markup://c:APStage2 is missing required attribute 'name'

Wrapper Component snippet which embeds APStage2 Component

<div aura:id="stage1Div">
    <c:APBasicInfo partnerRecord="{!v.partnerRecord}" />

</div>

<div aura:id="stage2Div">
    <c:APStage2 partnerRecord="{!v.partnerRecord}" />
</div>

Component:

<aura:component 
  implements="force:appHostable,flexipage:availableForAllPageTypes,
  forceCommunity:availableForAllPageTypes" access="global" 
    controller="AffiliatePartnerApexController">
  <aura:attribute name="partnerRecord" 
  type="Affiliate_Partner_Onboarding__c" access="global" />
<aura:registerEvent name="appEvent" type="c:AffiliatePartnerDetailEvent"/>
<aura:registerEvent name="bubblingEvent" 
 type="c:AffiliatePartnerSPANotifierEvent" />  
  • it is missing a required attribute 'name' --> name="something" =P – glls Aug 16 '17 at 20:40
  • If so, how it would work on the VF page? – JJSHHS Aug 16 '17 at 20:47
  • are you assigning name attribute from the wrapper in the contorller? have you marked it @aura enabled? Instead of us speculating can you post your component and controller? – Rao Aug 16 '17 at 20:49
  • @JJSHHS you will need to share some code (a minimal reproduceable example preferably) – glls Aug 16 '17 at 20:50
  • Try making a default value on your name attribute. Then use a design file to allow users to set the value from the app builder. – Caspar Harmer Aug 16 '17 at 20:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.