Since yesterday I'm getting a weird error while trying to access the Workbench: https://workbench.developerforce.com/ enter image description here

I've already tried with different browsers, flushed the dns cache, deleted all the cached data from Chrome. I've also tried using some dnslookup online tools, at the end I've tried to download the index page from a vps in the cloud using wget, but I always get the same "DNS address not found" error.

Is anyone experiencing the same issue / has found a solution / knows if it's a Salesforce problem?

UPDATE 17 August: the Workbench is back online. https://github.com/ryanbrainard/forceworkbench/issues/710#issuecomment-322800122


2 Answers 2


Found the issue.

The workbench is a third party tool managed by people that (apparently) have nothing to do with Salesforce itself, so the workbench is not a supported app. The certificate they were using has expired, they are trying to update it.

You can follow the issue here: https://github.com/ryanbrainard/forceworkbench/issues/710

A possible solution is to install the workbench locally on your server / local machine. Instructions can be found here: https://developer.salesforce.com/page/Workbench#Installation

  • 2
    Thanks @Alberto. This is the root of the problem. Also, I'm sure many of us never realised this is a third party application. Well done Ryan Brainard!
    – Dizzley
    Commented Aug 15, 2017 at 13:14
  • It's funny because when I started with Salesforce in my company last spring, the guy we hired for the ERP transition showed me the Workbench as "the tool" that Salesforce made to simplify our life. I guess he still has no idea that it's a third party tool :)
    – Alberto
    Commented Aug 15, 2017 at 13:51
  • 1
    As of today, the Workbench seems to be back online (issue closed in Github: github.com/ryanbrainard/forceworkbench/issues/… )
    – Alberto
    Commented Aug 17, 2017 at 7:12

"Try out Workbench at https://workbench.developerforce.com. Note, some of the limits and features are restricted for this demo for performance reasons." (Emphasis mine.) According to the Workbench page on Salesforce, he Developerforce Workbench page is a demo page, and I never found it to be reliable.

You can deploy workbench to Heroku yourself and not have to rely on the actual webpage. In short, clone, this repo, add the Phing buildpack, and push to Heroku. More details can be found in the "Deploy Workbench To Heroku" section of the Workbench page listed below.

Deploy Workbench To Heroku

  • The "demo" thing you see in the docs refers to the fact that if you have a developer edition only, you can only access demo data, so you are not going to use it for real. I'm using (I was, actually) the workbench on a enterprise edition, I shouldn't have to care about deploying the workbench anywhere, it should be granted to have access to it.
    – Alberto
    Commented Aug 15, 2017 at 10:15
  • 1
    Your Salesforce edition doesn't change your Workbench access - if you look at the last link in my post, you can see the broader context in which they say that workbench.developerforce.com is a demo. You are free to use that site, of course, and many people I know do. However, I have found the site to be unreliable; taking 30 minutes at most and getting Workbench up and running for yourself on Heroku might be time well spent. Commented Aug 15, 2017 at 10:23
  • I didn't get from the documentation that the "demo" word was referring to the website. I've always given as truth that the workbench was a salesforce tool, not a third party one. There are questions about the workbench in the certifications, the link "developerforce.com" redirects to developer.salesforce.com, so I was 99% sure it was a salesforce product. Thanks for clarifying this!
    – Alberto
    Commented Aug 15, 2017 at 10:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .