I am unable to delete the Entitlement Process from the salesforce. First I delete all the cases associated to that Entitlement process and also deleted from the recycle bean manually. Now when I am trying to delete that entitlement process it says below. What's wrong is happening ?

enter image description here

Now when I click on the any of the case, I see the below error message. Anyone please suggest whats the issue is and how to solved this? Any workaround to this ?

enter image description here

| improve this question | | | | |

You need to delete Entitlement records associated with Entitlement Process

| improve this answer | | | | |
  • This not about cases, this is Entitlement record, Entitlement Process is related to the cases via Entitlement record. – Santanu Boral Aug 13 '17 at 16:00
  • is that worked for you? – Santanu Boral Aug 14 '17 at 21:56
  • Are you saying that we should delete this using Program code? I dont see we can use DELETE in workbench ! – user4567570 Aug 15 '17 at 10:51
  • No, you can't delete through program code – Santanu Boral Aug 15 '17 at 13:56

@Santanu Boral - Mentioned correctly, you just need to delete all those cases (if you dont delete linkage of the case with Entitlement Process), you need to delete all those cases from recycle bin and need to wait for 2+ weeks, to get clean up processes completed from salesforce and then you can delete Entitlement Processes.

I have done this actvity many times as my org has almost 85 entitlement processes.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.