3

After deploying a change set to a Partial Copy Sandbox an object (only one it seems), in this case Work Orders, is viewable but NOT editable. We have numerous profiles but even mine, System Administrator, receives the same error when trying to update a record. The classic:

Insufficient Privileges You do not have the level of access necessary to perform the operation you requested. Please contact the owner of the record or your administrator if access is necessary. For more information, see Insufficient Privileges Errors.

Even when I am the owner of the record I couldn't save any updates.

As I am the record owner, system administrator with view/modify all on the object alongside having Modify All Data ticked.

I've recalculated our sharing rules and tried different profiles who should be able to edit the records. This change set had been tested in a different sandbox and that worked fine. This one hasn't.

Any obvious ideas? Is it one to speak to Salesforce Support about?

EDIT: nothing obvious in the changeset that should impact this.

1

It sounds as though your change set may not have included profiles. When you deploy an object, permissions related to the object are also affected. You'll either need to deploy the affected profiles or edit them accordingly in the org you deployed them to.

I'll add that it's not unusual for there to be problems when deploying profiles via changesets. This is a frequent problem that developers often encounter.

  • I've checked, it did include all of the profiles I expected (including System Administrator). The necessary changes to the profiles all seem to have deployed as well (when viewing the profile I can see the new access) – n34_panda Aug 12 '17 at 14:37
  • I recommend you try doing a redeploy where you deploy the object in one package, then the profiles in another one to see if it resolves your issue. You may be missing some other metadata as well such as a permission set, sharing rules, or similar that you may have also missed. Deploying profiles can truly be problematic when using change sets. – crmprogdev Aug 12 '17 at 14:57
  • I just did a Debug Log on my user as I replicated the issue. The Status shows "Internal Salesforce.com Error" but I am not incredibly sure what I am reading in the log. It looks like a trigger handler caused it but I am not sure I understand the relationship between the messages. – n34_panda Aug 12 '17 at 15:01
  • 5
    I found the problem via the debug log - we had a developer write some extra code for us and whilst it is meant to be tested it was causing the problem. I've disabled it and the users can read/write as expected. The Debug Log showed me where to look :P – n34_panda Aug 12 '17 at 15:24
  • Glad to hear you got it sorted. Debug logs do provide useful information, especially when you know how to interpret and utilize in the proper context. :-) – crmprogdev Aug 12 '17 at 19:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.