0

We have recently configured new environments and I as a system administrator is trying to create an Account of Certain Record Type but still It gives me Insufficient Privileges error.I have checked the Object Permission and it is Modify All for System Admin.In Lower Environment we did not face this issue.I am not sure what is wrong here. I have checked the Organization-Wide Defaults Setting and it Public Read only. I have also checked the field level security and it is ok.

I have checked the debug log and can not see any error message.

Can someone please tell me what else do I need to check here?

  • Is "Create" permission set? Is access to particular RecordType enabled? – kurunve Aug 7 '17 at 11:14
  • I have create Permission for Account object and the particular record type is also visible to me during Account creation.Problem occurs when I am trying to save the record. – Dhananjay Patil Aug 7 '17 at 11:18
  • Can you post what is exact error message, probably screenshot? Is there any other logic on account (trigger/process builder/etc)? – kurunve Aug 7 '17 at 11:26
  • 1
    If it's only of a certain record type, make sure that the Administrator profile also has that Record Type assigned to the profile. – sfdcfox Aug 7 '17 at 11:31
  • I have checked and confirm that Record Type is Assigned to Admin's profile.Problem occurs when I am trying to save the record. – Dhananjay Patil Aug 7 '17 at 11:37
1

When we create an account,Based on Department field(Type:Picklist),we assign Sales Rep(Lookup(User)) the respective account.For this we define Custom Setting.In Custom setting we define 3 different fields Department,UserId and User Name.

The privilege issue occurred because user id was not updated in Custom setting,it was referring to lower environment.

So whenever we create an account,it was trying to assign the user in Sales Rep field whose id does not exists in Org which was the reason we faced the error.

After updating user ids in custom setting,the issue is not replicated anymore.The environments that we setup is completely new environments and whatever users we have inserted in it has a different user id than other environments.

Lesson Learned :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.