0

Whenever I try to create a dataset in Wave Analytics using Salesforce,I get this error which says : WARNING: Your dataflow definition contains errors that will cause your dataflow to fail.

Fix these sfdcDigest node errors and then upload the file again:

In the '160' node, the 'Disable_VRules__c' field doesn't exist or isn't accessible to the Integration User. In the '160' node, the 'Hire_Date__c' field doesn't exist or isn't accessible to the Integration User. In the '160' node, the 'License_Allocated__c' field doesn't exist or isn't accessible to the Integration User. In the '160' node, the 'License_Pool__c' field doesn't exist or isn't accessible to the Integration User. In the '160' node, the 'License_Type__c' field doesn't exist or isn't accessible to the Integration User. In the '160' node, the 'Physical_Locale__c' field doesn't exist or isn't accessible to the Integration User. In the '160' node, the 'Product_Family__c' field doesn't exist or isn't accessible to the Integration User. In the '160' node, the 'Re_Hire_Date__c' field doesn't exist or isn't accessible to the Integration User. In the '160' node, the 'Term_Date__c' field doesn't exist or isn't accessible to the Integration User.

  • looks like the user doesn't have access to those objects, hence why you are unable to create the dataset – glls Aug 6 '17 at 19:11
1

Einstein Analytics dataflows run through the Integration User. If the Integration User profile does not have visibility for a field in the dataflow, it will cause the following error:

Error executing node sfdcDigest_Node: Field [Field_Name] is not available. Verify that the field exists and that the Analytics Cloud Integration User profile has Read level access on the field.

Dataflow Error "Field is not available" in Einstein Analytics

Determine the related Object

Retrieve the dataflow JSON through the following steps:

  1. Gear Icon > Data Monitor
  2. Change view to Dataflow View
  3. Click the dropdown options on the right side for the target dataflow and select Download
  4. Open the resulting file in your favorite JSON editor Locate the specified node to determine the object, this will generally appear as follows:
"sfdcDigest_Node": {

    "action": "sfdcDigest",

    "parameters": {

      "object": "Object",

Confirm Field Level Security settings

Review the Field Level Security for the Object within the Profile assigned to the Einstein Analytics Integration User. Ensure the profile has Read Access on the field(s) listed in the error. More information about managing FLS can be found here:

  • Setting Field Permissions in Permission Sets and Profiles

Check Managed Package access

Review the Custom Fields on the Object. Determine if they are part of a managed package. Ensure that the Integration User has the necessary permissions and/or licenses to access the managed package that contains the target fields. Methods for granting access to managed package components vary, reach out to the package creator for assistance granting access to its components. Restart Dataflow Once these items have been updated, you can re-run the dataflow by selecting Start from the dropdown menu in the Data Monitor.

  • consider accepting the answer if it helped you resolve your issue, =), glad i could help @Ravi Deshmukh – glls Aug 10 '17 at 15:28
  • Any ideas if the running user actually have access to the fields, in fact they can edit them from the object edit page? – manza May 10 '18 at 0:47
  • Actually you are right but perhaps if anyone is running the same issue, is not the profile of the current user is the profile of: Analytics Cloud Integration User and Analytics Cloud Security User, that is why i was getting confused – manza May 10 '18 at 0:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.