6

None command is possible to execute on DX CLI, from my company network.

It returns:

ERROR running force:org:open: connect ETIMEDOUT 13.108.249.193:443.

enter image description here

I know that DX CLI is based on Heroku and it uses Node.js

Looking for the same error on Heroku, people who faced the same issue has resolved when enabling Port 5000 (which is why I think it is blocked here in my network)

I also know that Node.js has its own proxy.

Has someone already faced this issue?

  • 2
    You might get better answers asking at the Salesforce Success Commnity for the beta? Theres a few SFDX devs in the group who might be able to help with your configuration. I'd also say its worth posting whatever answers you get here, for when SFDX is GA. – battery.cord Aug 2 '17 at 14:42
  • 1
    I will ask there too, and as soon I get the problem solved I will post the solution here too. Thank you – Leandro Ferreira Fernandes Aug 2 '17 at 14:48
  • just another reason salesforce doesn't get "Developer Experience". They need to open source the CLI so we can fix their crappy work – NSjonas Mar 20 '18 at 17:22
2

The problem is caused because you are behind a proxy. Try to execute the same command with a direct connection (for example phone tethering).

You can try to use a proxy

https://developer.salesforce.com/docs/atlas.en-us.sfdx_setup.meta/sfdx_setup/sfdx_setup_install_cli_firewall.htm

but for me, only works direct connection (I think is an issue)

0

I ran into this issue with an org that was using custom domain. I was able to fix it by using the domain (as it shows up when I'm logged in) instead of the generic https://test.salesforce.com or https://login.salesforce.com.

EG:

sfdx force:auth:web:login -sr https://mydomain--staging.cs25.my.salesforce.com -a sandbox-user

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.