0

I have an object A.

I created a new profile called Newprofile, which is basically a read only profile's clone, in which I have granted read permission to the custom object A only.

Now i created a new user named called NewUser and assigned this profile Newprofile to it.

Now I set public read to the object A in OWD(to my understanding thus granting read access to other owner's records).

Now when I log in as Newuser I can see the tab(after enabling the tab visibility in the profile) but i am not able to see any data records.

My Understanding of sharing in salesforce is that Profile is the baseline start, where permission set is used to grant more access when number of user(s) among the profile need extra access.Profile is only set for owner's own records. When we need to deal with other owner's records then comes in OWD, role and Sharing rule.

since I have set OWD to Public read i thought i would have access to the object A data records from the new user NewU even though the owner is different, and since the profile has Read access to the object it should be able to read the records

3

The default view of any object's tab is the "recent items" list. By default, this list is empty, since the user hasn't used any records yet. Instead, you need to go in to a List View to see records. In Classic, click on the "Go" button next to the View dropdown. In Lightning Experience, click on the Recently Viewed title and choose a List View. Once selected, the user will be able to see the records available for that object.

| improve this answer | |
0

your assumptions are correct.

Profiles / permissionSets give you object CRUD access (plus the option of View All/ Modify All).

Sharing rules and OWD then open up Row Level access for records you do not own.

If you have object access in your profile, and an object's OWD is set to public read only, then you will be able to see all the records of that object*.

*there is some special behaviour around contacts, accounts, contract and some standard objects, but we don't need to worry about that as you said this is for a custom object.

Can you please post a screenshot of the profile permissions for that object and a screenshot of the sharing rules section for that object. What you have said you've done should work, so something may be missing that you haven't noticed.

| improve this answer | |
  • Thanks for answering sunny, the trick mentioned above by sdfcfox did the trick. – Niknit Aug 2 '17 at 7:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.