0

I'm curious, has anyone got the package react-native-maps to work in the mobile SDK? I've been bashing my head against the wall for a while on this one now, so much so that i'd love some confirmation that this is indeed possible (building in iOS)..

I've tried the installation instructions here: Git Repo

Also, tried many other 'guides' on how to do this - the best one being this one (that actually works in vanilla RN):React Native Maps Guide

But cannot make this work in a mobile SDK deployment.. This definitely has something to do with the linking to the native code, the MapView component always spits out some variant of an 'undefined' error when running in the emulator..

0

Okay, hopefully this one helps for someone else searching later on. This, I find out after much wailing and gnashing of teeth, is due to the version of RN deployed in the Mobile SDK (v5.2) that I was using.

To make this work, I had to downgrade the react-native-maps package to 0.12.4 as there was a breaking change introduced in that package for later versions of RN.

I have this working now with the package at 0.12.4 and V5.2 mobile SDK.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.