2

My Salesforce1 lightning app has 2 main pages: an app landing page and an admin page (there are also several supporting pages).

I can successfully deploy all objects and code from my personal developer sandbox to the company org developer sandbox, and I am also able to assign a tab to the admin page, but the dropdown for assigning lightning components to tabs does not contain my app's landing page component. It does show my other components as well, just not the one for the main landing page. This is not happening in my personal developer sandbox - that works perfectly.

I have tried deleting the component bundle and re-deploying as well as adding it back manually, and I have also tried deleting many other component bundles and adding only that one back, but nothing works.

I will also mention the obvious:

  • I did set up a MyDomain and have logged out and back in several times
  • I do have implements="force:appHostable" set in the component in question
  • 2
    Update: I was able to deploy the tab using force.com IDE, however when I tried to edit it, it wouldn't let me save. This time it gave an error message: "You can only create lightning tabs for AuraDefinitionBundles containing a component that implements force:appHostable and has no required attributes without a default value. (Related field: Content)" Note: both of those conditions have been met... – Tim Thomas Jul 26 '17 at 20:48
  • I also tried creating an entirely new page using the content from the existing page and I still couldn't create a tab for it. – Tim Thomas Jul 26 '17 at 20:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.