0

I have a couple of Wave Dashboard that up until today have worked perfectly well. They utilize data from a single Data Recipe, primarily comprised of data from the Contact Object.

All Replications, Dataflows and Recipes compile and run just fine and are up to date. Nothing (to my knowledge) has changed in the dashboard code itself.

When I attempt to access the dashboard, I get an error screen with the message

Unable to open the dashboard. Something went wrong while displaying this dashboard. Try closing or reloading the dashboard. Otherwise, contact Salesforce Customer Support.

I click on show details and see

Cannot read property 'getDataSource' of undefined

That's it. I am stumped, though there's probably a simple explanation. Anybody deal with this or have ideas on how I can solve it? Or at least, how can I get more information about it? Like, is there a specific missing field that is causing problems?

7
  • if you go under Analytics>Browse All>Datasets is the dataset for that dashboard still there? maybe it was deleted?
    – glls
    Jul 25, 2017 at 21:37
  • That is a good guess, but it's still there. No underlying dataset changes at all that I can see. Dataset naming can be fickle in Wave. I don't see how, but it might be possible that something got renamed or otherwise changed. But the real puzzler is, I have other dashboards using the same dataset that are fine. Jul 25, 2017 at 21:48
  • under the data set, check that the columns are still there with data (eventhough getDataSource of undefined would suggest the dataset does not exist...) Maybe edit your dataset and click update, if none of the above works, maybe log a case with support as suggested by the error
    – glls
    Jul 25, 2017 at 21:51
  • can you share a screenshot of the dashboard (dashboardname summary) after closing the error box?
    – glls
    Jul 25, 2017 at 21:54
  • 1
    at this point i would contact SF support.
    – glls
    Jul 26, 2017 at 1:55

1 Answer 1

0

Problem solved (though not really figured out). The issue was with a couple Global Filters on the dashboard. Once removed from the JSON, things were back to normal. Salesforce support couldn't tell me why the Global Filters were the culprit, but they were.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .