0

I am trying to delete an object but when I try to delete it, the object says that it is being used by a Dataflow object. However, when I click on the link to view it, I get a "Insufficient Privileges" error with the message:

You do not have the level of access necessary to perform the operation you requested. Please contact the owner of the record or your administrator if access is necessary. For more information, see Insufficient Privileges Errors.

I am a System Administrator in my org.

0

If you have wave analytics, your object may be part of that dataflow json. You will need to modify your json first and remove that object from it. Then you should be able to delete.

If you downloaded the json and you searched via the object name, you should see it. I don't know anything in salesforce that uses dataflows except for wave.

If this worked for you please mark as answered and you can add any editorial that may help other users.

thanks

  • I have never interacted with wave analytics before. Would this be the correct resource to look at? developer.salesforce.com/docs/… – akcorp2003 Jul 24 '17 at 17:45
  • I don't believe we have Wave enabled for our org. – akcorp2003 Jul 24 '17 at 21:37
  • Ah. I believe I just enabled Wave and I tried looking at the dataflows. I downloaded the JSON files but I couldn't locate my object in them. – akcorp2003 Jul 24 '17 at 22:01
  • Looks like my solution was to modify the JSON through trial-and-error. Even though my object is not referenced in it, it's a mystery to why the Dataflow is being referenced. – akcorp2003 Jul 25 '17 at 18:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.