1

I have an automation to export all subscribers to fetch the "status" column. My shceduled automation extracts the all subscribers list and then drops the file on the dedicated FTP with correct name and file ending (.csv). But when i open the file it only shows hexadecimal characters, why is this?

Right now i have to steps in the automation, one data extract activity and one file transfer activity.

The configuration in the data extract activity is set to UTF-8 Encoding, Column delimeter is set to Default and the format is set to .csv. I've checked the options Extract Subscribers and Include All Subscribers. Does anyone know how to get the file content into readable text?

  • For some reason the file does not have .csv file ending after export even if its specified in the configuration of the data extract acitivty. Anyone knows why? – Axel Ekeberg Jul 17 '17 at 10:31
  • 2
    Tracking extracts are always .zip files. – Adam Spriggs Jul 17 '17 at 11:03
  • @Adam Spriggs - When i check the option "Unzip compressed file" in the File Transfer Activity after the Data Extract Activity, i get the erro message "File pattern is invalid. It must be of type: .zip, .tar, .gz, .tar.gz, .tgz". Isn't it .zip by default? It's the same error if i add .zip manually as well. – Axel Ekeberg Jul 17 '17 at 12:09
  • And the file doesn't have a file ending at all when it is dropped in the FPT folder which means i cannot create a File transfer activity as step 3 to unzip the file either. – Axel Ekeberg Jul 17 '17 at 12:38
  • 2
    In your file transfer, I believe you need to do yourfilename.zip, not yourfilename.csv - after it is moved onto your FTP, you should then be able to unzip it via the File transfer – Gortonington Jul 17 '17 at 12:53
2

I am assuming you are taking a tracking extract, so please see below for necessary tasks to export onto an FTP location and unzip:

  • Create and execute your data extract / tracking extract
  • Create a File Transfer to move onto FTP (Move a File From Safehouse)
  • Create a File Transfer to unzip your file (Manage File)


Details on these steps:

For the tracking extract:

  • Make sure to name the File with .zip. (e.g. Tracking.zip)

  • Format listed is the format of the files INSIDE the zip file.


For the Move From Safehouse File Transfer:

  • Make sure to set to "Move a File From Safehouse" for File Action
  • Mimic File Name from before (e.g. Tracking.zip)


For the Unzip File Transfer:

  • Make sure to set to "Manage File" for File Action
  • Mimic File Name from before (e.g. Tracking.zip)
  • Select 'Unzip compressed file' from File Management Actions
  • Make sure the file location matches Move From Safehouse File Transfer
1

Be sure you have not checked the 'File is compressed' checkbox in the File Transfer Activity. It could be that the file you are opening is a .zip file.

  • I dont see that option in the steps of the activity. I have choosed "Move a File From Safehouse" instead of the "Manage File" which had that option. If i choose "Manage file" option i get the error message "Automation Not Run. An error prevented Extract All subscribers automation from running. Please retry. Need more help regarding this error? Open a support case through the Help & Training Portal" when running the automation. – Axel Ekeberg Jul 17 '17 at 10:03

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.