2

I have a Visualforce page with an extension that is supposed to allow a community user to change their password.

When the logged in community user (User License = Customer Community) uses my page, the change password process returns a page message of:

The system is unable to change your password.

I've made sure the current password and password policies are adhered to. (they cause different messages anyway).

Has anyone received this message before, and if so, what's causing it?

Extension method:

public PageReference changePassword()
{
    // this always returns null.
    // if there are any errors, they're added to ApexPages page messages
    PageReference changePasswordReturnPage = Site.changePassword(newPassword1, newPassword2, password);

    return null;
}

Visualforce Page extract:

<apex:form>
    <apex:inputSecret value="{!pageExtension.password}" html-placeholder="Current Password" />
    <apex:inputSecret value="{!pageExtension.newPassword1}" html-placeholder="New Password" />
    <apex:inputSecret value="{!pageExtension.newPassword2}" html-placeholder="Repeat Password" />
    <apex:commandButton action="{!pageExtension.changePassword}" value="Change Password" rerender="change-password-result" />
</apex:form>
  • Check if the profile has 'Require a minimum 1 day password lifetime' enabled. If yes disable the same try with change password. – sukanya banekar Jul 13 '17 at 5:38
1

It appears this was an intermittent salesforce issue.

Without changing the code, the next day the Site.changePassword() method worked as expected.

It's a bit concerning, because it was never clear what the problem was. Using the System.setPassword() worked during this time period, so I'm not sure what problems salesforce was having, or how we're supposed to handle this properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.