7

When using the latest version of Google Chrome, the Layout Editor palette is empty, so we cannot add fields, related lists, buttons, or any other objects to the page. No console errors are reported. Will attach a screenshot for this issue. Other browsers such as Safari and Firefox are working correctly. No information appears in "Salesforce Known Issues" for this problem.

This is really more of a question to see if anyone else is experiencing this. I've included a screenshot of the issue to see if anyone else can add their experiences here. Is there any workaround, besides the usual "use a different browser" answer? The editor works just fine in Firefox, Internet Explorer, and Safari, all on the same computer.

I've also submitted case 09807031 to salesforce.com, in case anyone with any inside connections wants to look into this.

Chrome Bug-Winter 14

Update #1

Just tried this in Incognito mode, with extensions disabled, and the result is the same.

  • I just updated my chrome to Version 30.0.1599.101 m, No such error Sorry – TimChadwick Oct 18 '13 at 14:25
  • Which version of Chrome are you using? The beta version seems to have several rendering issues. – shannonsans Oct 18 '13 at 19:52
  • No issues. Tried to reproduce with GC 30.0.1599.69 on Macbook. – Ashwani Oct 19 '13 at 7:52
0

Try to disable all extensions or go into incognito mode and see if that helps. I had a different issue where the extensions I was using cause a conflict with a few pages. I agree with @TimChadwick I just tested with Chrome Version 30.0.1599.101 and do not have an issue.

Below is the HTML inside the left hand nav of the layout editor

<div id="troughSelector" style="overflow: auto; width: 136px; height: 130px;">
<ul>
    <li class="selected">
        <div class="selectorItem" id="troughCategory__Field">Fields</div>
    </li>
    <li class="">
        <div class="selectorItem" id="troughCategory__Button">Buttons</div>
    </li>
    <li class="">
        <div class="selectorItem" id="troughCategory__CustomLink">Custom Links</div>
    </li>
  • Occurs in Incognito mode as well, with and without extensions enabled. – sfdcfox Oct 18 '13 at 15:21
  • Interesting? Try comparing the page source of the fields window in Chrome vs the page source in the browsers that work. I'm curious to see if its being loaded at all or if its just hidden? (js maybe?) Also, if you run a debug using Chrome vs browsers that work do you see any errors/differences? – Ricky Hewitt Oct 18 '13 at 15:33
  • No errors in console. The only statistically interesting difference between the pages generated is that the CSS files use a directory called /base/ in Firefox, and /gc/ in Chrome. – sfdcfox Oct 18 '13 at 18:31
  • Are you having this across all objects in your org when using Chrome? Is the html <ul><li> code in the 'Fields Buttons, Custom links..." section. I've updated my answer to show the code I have in that section for reference. – Ricky Hewitt Oct 18 '13 at 20:46
  • Mine is missing two elements: <div id="troughSelector" style="overflow: auto; width: 136px; height: 130px;"><ul><li class="selected"><div class="selectorItem" id="troughCategory__values"></div></li></ul></div> – sfdcfox Oct 18 '13 at 21:05
0

I'm experiencing this same issue, as well as certain visualforce pages in Salesforce not fully loading (it gets stuck 50% through loading the page).

But I definitely am still experiencing this issue with Page layouts. I need to go to firefox every time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.