1

I learned a new requirement that now the rollups must be filtered on a third criteria. (This will mean creating 62 new fields to capture the rollups... but I digress). So I added this new, tertiary criteria.

However, it's not working. I have checked and re-checked and re-re-checked. New criteria in circled in red on the image. Prior to adding the new criteria, the rollup was working across all opptys that met the stage and competing criteria.

enter image description here

I ran a query with those criteria to ensure there are records that meet them, and that I wasn't missing something.

enter image description here

  • In theory it should be functionally equivalent, but why use IN instead of =? Also, check FLS that you have read access to that field. – Adrian Larson Jul 12 '17 at 13:39
  • 2
    Thanks, @AdrianLarson. I originally had = 'Aerosol Fill'. Tried 'in' as a desperation move. Thanks for the tip - all criteria fields are visible to all profiles. – Alexx Jul 12 '17 at 14:39
  • Yeah all looks in order to me so it's the only thing I could think of. You might try switching to some parameter which is obviously true like Id != null so you can verify if it ever works with a third criterion. I admit I'm stumped. – Adrian Larson Jul 12 '17 at 14:47
  • I tried that and no dice. I'm not sure what the hiccup is. I literally took an existing, functional rollup and added one criteria, and changed the destination field for the calculated rollup value. – Alexx Jul 12 '17 at 16:31
0

Chalk this one up to "wrong field". Ammonia, Aerosol, Antimony... :/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.