7

I tried to deploy reports and report types thru Force.IDE. I observed that the reports other than the Joined format were not creating any errors while deploying, but the joined reports were creating some errors. While looking at the log report it says:

# Deploy Results:
   File Name:    reports/CustomReports/OccupiedRep.report
   Full Name:  CustomReports/OccupiedRep
   Action:  NO ACTION
   Result:  FAILED
   Problem: n/a

   File Name:    reports/CustomReports/taskRep.report
   Full Name:  CustomReports/taskRep
   Action:  NO ACTION
   Result:  FAILED
   Problem: n/a

   File Name:    package.xml
   Full Name:  package.xml
   Action:  UPDATED
   Result:  SUCCESS
   Problem: n/a 

Anyone ever come across this problem? How can I solve this?

2
  • Do you have any further details to add to your question? I am sure when you use the Deploy to Server feature in Eclipse you also can scroll down or show further details. Anything else to add? Oct 23, 2013 at 11:07
  • Is it relying on any Custom Report Types that might not have been deployed?
    – Mike Chale
    Oct 23, 2013 at 12:31

2 Answers 2

1

while it's substantially less user friendly, I wonder what would happen if you tried doing your deploy via the ant migration tool? Yes, I hate XML as much as the next 10 developers and I despise ant (who names software after a bug, isn't that bad karma?) but it does often provide a finer grained control of a: what's supposed to happen, and b: what did happen (in terms of logs dumped to your screen.)

Failing that, Have you tried deploying via MavensMate ? Functionally, it deploys via the same mechanism, but it stores the xml files and logs for review. It'd be helpful to see the xml (in a gist) that you're using to deploy. The "action: NO ACTION" makes me suspicious.

0

Joined Reporting must be enabled in the destination org.

From the setup screen go to:

Setup > App Setup > Customize > Reports & Dashboards > User Interface Settings

Then "Enable" the Report Builder Upgrade.

Enable Report Builder Upgrade

Voila! You should now be able to deploy your joined report in the destination org.

Source: http://www.nimbleams.com/blog/2012/4/20/salesforce-turning-on-joined-reports/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .