4

I've already added the new task in the Salesforce1 and Lightning Experience actions but when viewing it in the detail page, there's no new task. May I know why is that?

This is the screenshot of the actions in my Salesforce1 and Lightning Experience. enter image description here

And this is the screenshot of the detail page enter image description here

Thanks in advance.

3 Answers 3

7

When viewing the Activity composer related list, you may notice that some activity actions within the lightning experience do not appear on records even though those actions have been added to the Salesforce1 and Lightning Experience Actions section.

Example:

-New Event

-New Task

-Log a Call

If any of the actions above are missing and you have checked the page layouts to ensure they have been added, then it may be related to not associating a record types with any of those 3 specific global actions.

To confirm this,

  1. In the Lightning Experience, Setup Home | User Interface | Global Actions | Global Actions
    • In Aloha Classic, Setup | Global Actions
  2. Click Edit next to any of the missing global actions (New Event, New Task, Log a Call)
  3. Look at the 'Record Type' pick list and see if the selected value is Not one of your custom record types or if it says --Master--

Resolution
To resolve the issue, you will have up update the Record Type to be set to a default value that is one of the custom record types. --Master-- will not work.

Note: If you have no custom record types for these objects (Tasks, Events) then you won't be able to select any Record Type. If you do have custom record types, it needs to be associated with the global action to work in the lightning experience under the Activity composer.

2
  • Thank you so much @Diksha Goel. We just do these way and it works fine.
    – JMRAF69
    Jul 5, 2017 at 6:50
  • I had the same problem just now. For me, it wasn't a global action but an object-specific action (e.g. opportunity action) that needed to be changed.
    – Semmel
    May 10, 2022 at 19:17
0

I have tired it in my org and its working fine. Try this out - Select a record of your respective object - Goto setup (gear icon) > Edit Page > Add Required Component or Action > Click On Activation > Set As Org Default and save

0

I just had a similar issue where the standard New Task button was not appearing for one profile.

Cause: For profile in question, the Task object's default record type was erroneously set to managed package record type.

Fix: Since this was done in mistake, and we do not want that managed package record type to be the default, this profile's default record type was changed to be the same as other similar profiles. Go to Profiles > [Profile the New Task button does not show for] > Object Settings > Tasks > under section Task: Record Types and Page Layout Assignments. Now select the correct default record type for that profile.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .