0

I'm running into several problems about Triggered Send in Marketing Cloud. I connected my Marketing Cloud with Service Cloud Sandbox and now I'm trying to configure Triggered Send in order to send transactional emails every time an trigger event on Salesforce Object happens. As the documentation reports: I wrote a trigger class like this:

    trigger Trig_Object Name on Object Name (after insert, after update) { 
    et4ae5.triggerUtility.automate('Object Name'); }

For istance I tried to configure a triggered send on Case object when status on Case becomes "Confirmed". I configured the triggered send and activeted it but nothing happened and no email was sent by Marketing Cloud, futhermore I received also an error like this when I'm tried to test trigger class: FATAL_ERROR et4ae5.MCBaseException.InvalidParameterException Where am I wronging? Thanks for your feedback. Alessia

  • It might be helpful if you take a screenshot of your trigger configuration for everyone to see. Also ensure you're targeting the right object type. – Amtera Jul 4 '17 at 8:21
0

That did not work for us. Exluding the call to the MC class did the trick:

trigger ContactTrigger on Contact (after insert, after update) {
    if (!Test.isRunningTest()) {
                et4ae5.triggerUtility.automate('Contact');
    }
}
0

You are facing these issues because the marketing cloud connect has been updated to version 208.1. I raised a case with Marketing cloud Team and following was their response.

  1. Test class issue: It is a known issue and they are working on it.
  2. Triggered send not working: You can configure triggered sends through exact target instead of your salesforce org. Following are the steps:
    • Select the triggered send
    • Pause it.
    • Do the required changes.
    • Publish the changes
    • Click on start/restart to start the triggered send

Update the Marketing Cloud Connect version to 208.2 and it will resolve the test class and Triggered send issue

Refer Install Marketing Cloud Connect for package installation

  • Thanks for you feedback Ankita, Do you know when Salesforce will be able to solve this issues? It's a big problems! Without test class -as you well know- I won't be able to release my change set in production. In stead for the triggered send I will test your solution and let you know if It will work. – Alessia Annella Jul 4 '17 at 9:52
  • I don't know the specific date. But, they are addressing this issue. You can try to update the Marketing Cloud Connect version to 208.2 and check if it works. But, again updating the version might add up some more known issues. – Ankita Jul 4 '17 at 10:06
  • Hi @Ankita, unfortunately even the solution you proposed isn't working. For you did it work? Do you know any other workaround? – Alessia Annella Jul 5 '17 at 9:01
  • Hi @AlessiaAnnella, try to send your email using a Test Send and check if you are receiving the email. Then, you should look into Triggered Send – Ankita Jul 5 '17 at 9:04
0

Unfortunately, in version 214.0.2 it's still not fixed... I've tried seeAllData, login as our MC admin user and other things but nothing helped.

I've opened a case for that and will update once I will get an answer.

The error message that I've:

FATAL_ERROR et4ae5.MCBaseException.InvalidParameterException: Whoops! Marketing Cloud Connect does not have access to the selected object. Contact your administrator to enable objects for Marketing Cloud Connect triggered sends.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.