0

I am using .netCore to connect to exactTarget api using soapClient. The method exposed in .netCore for soapClient is "RetrieveAsync".

How could I send the request object?

This is how i connect:

created a soapclient object -> _etSoapApiClient = new SoapClient(); Used this object to -> await _etSoapApiClient.RetrieveAsync(retrieveRequest1)

I am getting error:

  1. Waiting for Activation
  2. Security requirements are not satisfied because the security header is not present in the incoming message
  • what documentation are you referring to? maybe you can link and quote the part of the doc that mentions how to connect? so others can help you pinpoint what you are or aren't doing wrong? A Minimal code sample (without actual credentials) could also help other identify what the cause might be, Thanks – glls Jun 28 '17 at 20:11
0
  1. Waiting for Activation
  2. Security requirements are not satisfied because the security header is not present in the incoming message

For the first issue can you try the Retrieve() method instead of the Async version just to see if the results are returned.

The second issue is related to your web.config - ensure it looks something similar to this, making sure your webservice URL is correct for your environment.

<bindings> 
    <customBinding>
        <binding name="SoapBinding" closeTimeout="00:30:00" openTimeout="00:30:00" receiveTimeout="00:30:00" sendTimeout="00:30:00">
            <security authenticationMode="UserNameOverTransport">
                <secureConversationBootstrap />
            </security>
            <textMessageEncoding messageVersion="Soap11WSAddressingAugust2004" />
            <httpsTransport maxReceivedMessageSize="655360000" />
        </binding>
    </customBinding>
</bindings>
<client>
    <endpoint address="https://webservice.exacttarget.com/Service.asmx" binding="customBinding" bindingConfiguration="SoapBinding" contract="ExactTargetClient.Soap" name="Soap" />
</client>
| improve this answer | |
  • as i am trying to connect from .net core the only method exposed is retrieveasync. – user46625 Jun 29 '17 at 14:04
  • so i just have to add to webconfig? and it shoudl work? – user46625 Jun 29 '17 at 14:05
  • Sure, I ran across the web.config issue a few times and the change I noted in my answer will fix that – Amtera Jun 29 '17 at 14:06
  • i tried it and it dint work. same security header issue. – user46625 Jun 29 '17 at 14:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.