0

I was previously using version 4.9.2 of the marketing cloud SDK on Android to recieve notificaitons and it all worked fine. However after updating to 5.0.4 I get the following exception in the log when a notifcation is receved from GCM:

E/~!PushMessageManager: Unable to show GCM notification Sdk Version: 5.0.4 Google Play Services Version: 10240000 java.lang.IllegalStateException: Missing required properties: id at com.salesforce.marketingcloud.notifications.$$AutoValue_NotificationMessage$a.c(Unknown Source) at com.salesforce.marketingcloud.notifications.NotificationMessage$a.d(Unknown Source) at com.salesforce.marketingcloud.notifications.NotificationMessage.a(Unknown Source) at com.salesforce.marketingcloud.messages.push.PushMessageManager.a(Unknown Source) at com.salesforce.marketingcloud.messages.push.PushMessageManager.a(Unknown Source) at com.salesforce.marketingcloud.messages.push.PushMessageManager$a.onReceive(Unknown Source) at android.support.v4.content.LocalBroadcastManager.executePendingBroadcasts(LocalBroadcastManager.java:297)

I know I'm probably doing something wrong somewhere, but I'm struggling to find where the required "id" propertly I'm missing would be.

Any tips would be appreciated!

Thanks.

  • How are you sending the push notification: via the Marketing Cloud or via some other method? – Bill Mote Jun 21 '17 at 13:58
  • That was from our own server communicating with GCM. However I have tried sending a push notification as mentioned in step 7 of the help guide (salesforce-marketingcloud.github.io/JB4A-SDK-Android/…) and this error also occurs. – Jamie Trinder Jun 22 '17 at 8:28
  • Hi Bill, has there been any update on this yet? Thanks. – Jamie Trinder Jun 28 '17 at 8:54
  • I got this issue and solved, you can find in this. – DomonLee Jun 21 '18 at 6:14
1

You must provide the id field _m in the payload.

Please see troubleshooting docs: http://salesforce-marketingcloud.github.io/JB4A-SDK-Android/trouble-shooting/trouble-shooting-push-setup.html

-1

We ran into this issue as well. The solution (for us) was to use the Legacy Server Key from the Firebase Console (not the regular server key). Hope this helps.

  • Hi Shane, thanks for the tip, I'll give this a test soon! – Jamie Trinder Jul 21 '17 at 8:22
  • Unfortunately I must have already been using the legacy key, as the same issue occurs. – Jamie Trinder Jul 21 '17 at 15:20
  • The error message, Missing required properties: id means you did not include a message id in your payload. – Bill Mote Jun 20 '18 at 12:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.