0

I would like to send a triggered SMS using messageContact method without subscribe the contact to the appropriate short or long code and keyword (I know that's a prerequisite for sending SMS in Journey Builder, but i dont want use it!).

I think that I've implemented correctly the call because the response contains the tokenId and not an errore message.

The call is

{
"MobileNumbers": [
        "<mobile_number_with_int_call_prefix>"
    ],
    "Subscribe": false,
    "Resubscribe": false,
    "Override": true,
    "messageText": "HELLO WORLD",
    "SendTime": "2012-10-05 20:01"
}

But no messages have been sent... any idea?

  • Are you trying to contact them without them opting in? – Samuel Dare Jun 20 '17 at 23:26
  • Yep, i want to send a transactional SMS – Andrea Messini Jun 21 '17 at 7:35
0

My thought would be to do with the "MobileNumbers": - try using camel case

"mobileNumbers": []

  • I've tried it and the result is the same. – Andrea Messini Jun 21 '17 at 9:14
0

We have a similar scenario. Set subscribe and resubscribe to TRUE and add Keyword: [your keyword you already created in mobile connect here] That way they always get it. Better suggestions also welcome:)

0

I am experiencing the same scenario where it seems like the only way, via messageContact, to send to a number that doesn't already exist in MobileConnect is by subscribing them to a keyword. As the messages that I'm sending are intended to be one-time transactional sends I am going the route of setting them as "Subscribers" with a specific identifier as a prefix to the SubscriberKey value. My thinking is that this will allow for easily segmenting and, perhaps, purging of these contacts after they've been sent to.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.