1

I retrieved an object using ant tool using retrieveUnpackaged command.I retrieved this from a higher environment of my project.. say the SIT environment(Full Sandbox). On looking at the fields( text fields only) I found that it has a property <encrypted> added to it like below. This is a normal text field and not encrypted type.

<fields>
    <fullName>atext__c</fullName>
    <deprecated>false</deprecated>
    **<encrypted>false</encrypted>**
    <externalId>false</externalId>
    <formula>xxx</formula>
    <label>xxx</label>
    <required>false</required>
    <trackHistory>false</trackHistory>
    <trackTrending>false</trackTrending>
    <type>Text</type>
    <unique>false</unique>
</fields>

On checking the field on Custom object from the UI , I do not see any property for encryption available. I thought , ok! this must be added by salesforce by default for all text fields. hmmm.. But I retrieved the same object from by Development org(DEV) and I noticed that there is no such property there:

<fields>
    <fullName>atext__c</fullName>
    <deprecated>false</deprecated>
    <externalId>false</externalId>
    <formula>xxx</formula>
    <label>xxx</label>
    <required>false</required>
    <trackHistory>false</trackHistory>
    <trackTrending>false</trackTrending>
    <type>Text</type>
    <unique>false</unique>
</fields>

I have been now wondering why the object from SIT org has <encrypted> added to it but it not in DEV org. Anyone had this discrepancy? or any reason Salesforce would add this property to a Full Sandbox org but not to a developer pro/developer org?

Update: I see that platform encryption is created under setup->platform Encryption in Full Sandbox but it is not there in Dev Sandbox. This be the reason?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.