We have been using rich text field from years, but recently we observed that there is some issue with it in community. I created a simple VF with just rich text field in it. This works properly inside salesforce. enter image description here

But, same VF in community looks like this enter image description here

Anyone aware about this issue?

  • Please check if this is the issue help.salesforce.com/…
    – Saroj Bera
    Jun 16, 2017 at 13:33
  • @SarojBera i tried doing same. As well as tried by new installed browser and on completely new PC, but same issue. Jun 16, 2017 at 14:20

2 Answers 2


Sorry for answering directly, but have enough reputation to put a comment.

This link here mentions that when Locker Services are enabled in the org, Rich text-area fields work in classic but do not show properly in other views. This is applicable for Communities as well.

As a resolution (temporary one) you can disable Locker Services and check if they have any impact on the Rich Text area fields.

This will be resolved when Locker Services are auto-enabled in Summer 17 release.

  • My sandbox is Summer 17 enabled, as well as, i am not sure if this is applicable for Communities or not. Because this works in my production, issue is with all my sandbox's. And upto what i have seen is, in locker services, the Rich Text is disabled, whereas this is just icons displayed incorrectly Jun 16, 2017 at 14:22
  • If so, I suspect it has something to do with cache. Have you tried deleting the cache and then doing a hard reload using Chrome Dev Console? Jun 16, 2017 at 14:47
  • Yes, i tried doing so. Also, opened same in completely new PC where salesforce was opened for the first time. Jun 19, 2017 at 6:42

This was reported in multiple complaints in both 'answers' and the developers forums. The solution is to clear the browser. My assumption is that it relates to a recent bug/change in SalesForce implementation of the CKEditor. No official statement or customer notification from SalesForce as of yet.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .