0

i want to add images in a Dashboard.

https://releasenotes.docs.salesforce.com/en-us/summer17/release-notes/rn_bi_wave_charts.htm under "Enhance Charts with Icons" This glorious little guide here tells nothing about the exact file / URL parameters.

So I tried at least for now 6 hours to enable pictures. I used SF "Files" in Libraries, the ContentObject, the Document Object etc. NOTHING worked.

How even to specify the picture link? is it SFinstance.com/ObjectID oder is it the exact image URL (with .png)?

The only thing that worked for me so far is the dynamically generated image URL with .png (and some cryptic stuff) from single uploads to the documents.

But i want to use 200 pictures. I dont search 200 urls by hand. I can't get them by reports or fit them together because there is some dynamically generated stuff in them.

How do you to that? As it is stated "https://myorg.content.force.com/file-asset/flagchinapng" ... .what is "file-assets" Is it Files oder Documents??

So the problem lies in getting the right picture URL. I can see grey icon placeholders in in dashboards/widgets/steps. So SF just cant parse the right URL.

1
  • Now i found out that i need some "special" link, that i used, when it worked with document attachments (png). So i uploaded a bunch via dataloader and got the long IDs back 0150Y0000018xgNQAQ (note with last 3 Characters QAQ,QAA and so on). As you can see in screenshot I also tried, as every normal human being would expect that the object url works "eu11.salesforce.com/0150Y0000018xgNQAQ" (note 18 Chars) - but it does not (step 2 in screenshot) Screenshot: imgur.com/a/ZgC1h Also with only 15 Chars it wont work (see step 3 in screenshot)
    – v3r0x
    Jun 14 '17 at 13:18
0

images that are needed should be uploaded to attachment object and then their ids are to be used.As of my knowledge, only attachments work here and final URL should look something like this

https://<yourorg>.salesforce.com/servlet/servlet.FileDownload?file=<attachment file id>

I tried all the possible ways only this is what I was able to work with

1
  • This is the "old" Attachments object, and NOT "Files", right ?
    – altius_rup
    Feb 22 '19 at 10:27
0

There is a Salesforce Known Issue precisely on this subject : https://success.salesforce.com/issues_view?id=a1p3A000000elGGQAY

Please click on "This issue affects me" to increase pressure on Salesforce to fix it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.