0

I have an object on a child relationship that has a formula that shows the name of the parent record, but Salesforce automatically tries to convert it to a link.

The record name is like XXXX.XX.XXXX, and Salesforce shows me a link on the related list pointing to XXX.XX domain. I want to avoid this hyperlinking, how can I do this?

The formula used on the field is like the following:

ParentObject__r.GrandFather__r.Name

And it outputs a string that has a dot on the name, that is interpreted like a link.

This is what it looks like on the record's related list:

records related list

This is the URL that they point to:

enter image description here

  • 2
    Can you give an example of the formula you have now? Formulas should show text output if you selected text as the formula type unless you put HYPERLINK() around it. – Dan Wooding Jun 9 '17 at 18:04
  • Added the example. – Renato Oliveira Jun 9 '17 at 18:27
  • I'm stuck, I can't reproduce what you're doing, I created a formula on Account because I have a 3 tiered account hierarchy so it's easy to pull in the same sort of formula with two lookups. The result was text each time with no hyperlink. I even tried putting dots in the name.. same result. I tried chrome firefox and IE. same result text only. Have you tried with different records name to see if you get the same results? – Dan Wooding Jun 9 '17 at 18:59
  • The formula output is like this: XX.XX.00.0000. Have you tried with two dots, instead of one? – Renato Oliveira Jun 9 '17 at 19:06
  • Can you try logging in using a different browser and then share the results? – night crawler Jun 9 '17 at 21:00
0

I'm 99% sure this is your browser. Replicating in a sandbox with multiple browsers did not reproduce the result at all. It looks like this is Looking through the internet it looks like this is an always-on feature where Chrome tries to help you and show links in the status bar.

So somehow Chrome thinks the XX.XX is a url, which it sort of is but it is not in this use case. I remember way back in the day turning off a browser setting where email addresses would show up with mailto: in the status bar and would try to open an outlook window if you accidentally clicked on it. Unfortunately, I cannot find that setting anymore.

I think the solution for you is to try a different browser or not use XX.XX in your record name.

Sources: https://superuser.com/questions/623505/turn-on-the-link-hover-statusbar-in-google-chrome

https://chrome.google.com/webstore/detail/link-revealer/nphhadgebjlmcfleikmiedhohdfbfoin

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.