6

enter image description here This is a Summer '17 Developer org.

I have a Napili Community I created this week called "bikes." This morning I log into my org and see that the Builder and Workspaces links are not available and the Community URL is not linked.

My user is a System Administrator and last time I checked, I was the only profile allowed to access the community. Anyone have any clue as to what the problem is?

Thanks in advance.

1
  • 1
    This looks like you will need to raise it with SF support as you clearly have the permissions to manage communities as you have access to the workspace and builder on the other communities. It might be worth getting metadata out for the community using workbench or an IDE using -<types> <members>*</members> <name>Network</name> </types> to compare the community access settings.
    – Dave Humm
    Jul 10, 2017 at 8:13

5 Answers 5

6

Per @Dave Humm's original comment, I discovered that it's possible to remove your access to a Community Workspace | Builder links in Administration from inside the portal by removing the System Administrator profile from the Settings -> Community Members within the builder. You will start getting errors in the builder after you do this. enter image description here

You can restore access by using the metadata API to update the Network for your community to list the profile Admin

As an aside: Community Experience builder is a really lousy product UX IMOP

...
    <networkMemberGroups>
        <profile>admin</profile>
    </networkMemberGroups>
2
  • Worked a treat, thanks! Jul 27, 2021 at 13:32
  • worked like a charm, thank you!
    – Sriram
    Sep 29, 2022 at 5:29
1

Go to the System Administrator profile and check for the community permissions.

0
1

Go to the "System Administrator" profile and then check for this enter image description here

1
  • 2
    I have tried this solution and it didn't work. Oct 13, 2020 at 15:28
1

Problem: Workspace link beside community URL is hidden .

Resolution :

  • Login into SFDC with system admin user
  • Go to All Sites (lightning experience)
  • Click on inactive community URL and right click-->inspect
  • You will get network id in HTML -->Copy that
  • Go to workbench /Data loader -->
  • Now you have to insert one record -->Object -->NetworkGroupMember
  • ParentId-->mapit to system Admin profile id Network ID -->map to ID you got in 1st step
  • insert that record .

Check your workspace link will be visible .

0

Add the user's permissionset/profile as community members. Owner who has created the community will have option to add members for the community portal.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .