0

I have a lightning component that I created in my Developer Salesforce Account and I want to export my managed package to an another Salesforce Account.

I sucessed to create my managed package and install it in the other Salesforce Account (with also this component).

But the problem is : When I am in the other Salesforce Account and I am adding a new Action with the option Lightning Component , it is writting me Error: No Lightning Component Quick Actions are available for your organization.

I tried to do it with an unmanaged package in the other Salesforce Account and it is working , so I think that the problem is related to the managed package

Can you help me with this problem thanks you very much

The code of the component is here:

DecryptService.cmp

<aura:component controller="testspace0001.EncryptionService" implements="force:lightningQuickAction,force:hasRecordId" access="global"> <aura:attribute name="listOfValue" type="List" access="global"/> <aura:handler name="init" value="{!this}" action="{!c.init}" access="global"/> <aura:iteration items="{!v.listOfValue}" var="item"> <p>{!item}</p> </aura:iteration> </aura:component>

DecryptServiceController.js

init: function(cmp) {

    var list = [''];
    cmp.set('v.listOfValue', list);


    var action = cmp.get("c.decryptDataLightningVersion");
    action.setParams({
        id : cmp.get("v.recordId")
    });

    var myList = new Array();
    var error;

    action.setCallback(this, function(response) 
    {

        var state = response.getState();
        if (cmp.isValid() && state === "SUCCESS") 
        {
            for(var i=0 ; i<response.getReturnValue().length;i++)
            {                   
                if( i==0 && response.getReturnValue()[0][0].startsWith("Error"))
                {
                    myList.push(response.getReturnValue()[0][0]);
                    break;
                }
                else
                {
                    var temp=response.getReturnValue()[i][0];
                    temp+=' : ';
                    temp+=response.getReturnValue()[i][1];
                    myList.push(temp);
                } 
            }                              
        }
        else if (cmp.isValid() && state === "ERROR") 
        {
                error = 'Error , please contact your administrator';
                myList.push(error);
        }
        cmp.set('v.listOfValue', myList);             

    });
    $A.enqueueAction(action);
}

Add new action

  • did you tried with access with public/Global – Raj_SFDC Jun 7 '17 at 11:23
  • What do you mean ? the class EncryptionService is already Global global class EncryptionService and also the function decryptDataLightningVersion is already a web service @AuraEnabled webservice static List<List<String>> decryptDataLightningVersion(ID id) – Raphym Jun 7 '17 at 11:51
  • Access specifier for lightning component.. – Raj_SFDC Jun 7 '17 at 12:03
  • @Raphym Did you register your domain in targeted salesforce account ? – Sagar Thoriya Jun 8 '17 at 13:43
  • 1
    I had the same issue intermittently the last day or two. Did you by chance update / change the API version between packaging and developing? This error can also occur if there's something not quite right with your cmp - it saves nice, works in dev org but not in package. Packaged cmps seem to be treated more strictly. For example I dont think handlers have an access attribute (<aura:handler name="init" value="{!this}" action="{!c.init}" access="global"/>) so id remove this first and then remove the next part until it works in the package – Christian Szandor Knapp Jun 8 '17 at 15:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.