1

I am trying to import a .csv file that contains commas in the data.

I tried to import it using Data Import Wizard using a tab as a separator but the Data Import Wizard doesn't detect the sublime text tab.

Is there a way to escape the comma when using comma as a separator?

  • There is no way to escape a coma. – Adrian Larson Jun 1 '17 at 14:53
  • @AdrianLarson I know you can't "escape" a comma, but if you wrap the field in double quotes as per the rfc this should solve the problem. – Jesse Milburn Jun 1 '17 at 15:41
  • @JesseMilburn OP wrote coma, not comma. I edited the post for clarity. – Adrian Larson Jun 1 '17 at 15:44
1

Fields with embedded commas must be delimited with double-quote characters. From documentation

the problem is that there is no unique standard for csv format. So the only option to read comma is to enclose it with double-quote

  1. Fields containing line breaks (CRLF), double quotes, and commas should be enclosed in double-quotes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.