0

I'm using Force.com Migration Tool to migrate metadata between two orgs. Everything is migrating correctly except a Dashboard. I'm getting the below error:

Error: Metric, gauge, or table dashboard component missing indicatorLowColor attribute (line 70, column 33)

Out of these three types above I only have one table dashboard component, and Salesforce UI doesn't give me any option for setting that missing colors.

If I comment out the dashboard in package.xml file, deploy passes successfully, and all reports that are included in that dashboard are migrated normally.

Not sure if this is important, but this dashboard is made with "Lightning Dashboard Builder".

Has anybody faced an issue like this?

5

I managed to solve this for now, but it's far from perfect.

Basically, after I pulled the dashboard metadata from source org, I opened it and found the <componentType>Table</componentType> tag, and right under it I added this:

<indicatorHighColor>#00716B</indicatorHighColor>
<indicatorMiddleColor>#ffb75d</indicatorMiddleColor>
<indicatorLowColor>#C23934</indicatorLowColor>

After this change I managed to deploy everything to my destination org, and everything seems to be working fine.

The downside is that this solution would require me to manually paste the above code everytime I need to deploy this dashboard.

  • 1
    What you talking about? THIS is PERFECT! – compski Jan 14 at 8:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.