0

I have developed a Custom Lightning component: Intake form, which has input fields of custom objects. I am using this component on my Community(Napili)'s page which is publicly accessible.

This component is being accessible only for the Logged in Community user with user license: Customer Community Plus Login. Even the page is publicly accessible, why the component is not being displayed without a logged in user?

FYI I do have access="global" attribute on the Component as well.

  • 1
    does your guest user profile have read access to the object(s) related to your custom component? – glls May 26 '17 at 5:27
  • @glls There won't be any guest users. It should be open to public. The form could be a source for submissions for people who don't have an user account at all. Just visit the page, fill the form and submit it. – Arnold Jr. May 26 '17 at 12:33
  • 1
    I understand. However, when you make your community public, umauthenticated users will use a certain profile. Usually with guest user license iirc. This profile should have read access to the components object. – glls May 26 '17 at 16:18
  • Cool. That helped. I have no-access to the fields on the Community Portal Profile initially. \m/ – Arnold Jr. May 26 '17 at 17:57
0

As mentioned, unauthenticated users will be using a certain profile which is accessible from the General Settings in the community builder as follows: enter image description here

you want to make sure (in my case) the getting started profile has access to the objects in your custom component (at least read access) under the profile settings.

you can find in the documentation steps on how to achieve this.

For template-driven communities, you can also access the guest user profile from Community Builder settings. Click General and then click the link under the Guest User Profile section.

  • My issue was resolved after giving the R/C access to the fields that are on the Component's form. All good. Thanks. – Arnold Jr. May 26 '17 at 18:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.