3

I am doing the SOAP Trailhead tutorials from the link: https://trailhead.salesforce.com/modules/api_basics/units/api_basics_soap. While executing the SOAP web service I am getting the below error.

Note: I am already using Prod org., Since I am administrator so that I already have Permissions Required

A user must have the following permissions:

  • View the CRUC setting: View Setup and Configuration
  • Activate or Deactivate the CRUC setting: Customize Application and Modify All Data

Here is the error message

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:sf="urn:fault.enterprise.soap.sforce.com" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
   <soapenv:Body>
      <soapenv:Fault>
         <faultcode>sf:UNSUPPORTED_CLIENT</faultcode>
         <faultstring>UNSUPPORTED_CLIENT: TLS 1.0 has been disabled in this organization. Please use TLS 1.1 or higher when connecting to Salesforce using https.</faultstring>
         <detail>
            <sf:UnexpectedErrorFault xsi:type="sf:UnexpectedErrorFault">
               <sf:exceptionCode>UNSUPPORTED_CLIENT</sf:exceptionCode>
               <sf:exceptionMessage>TLS 1.0 has been disabled in this organization. Please use TLS 1.1 or higher when connecting to Salesforce using https.</sf:exceptionMessage>
               <sf:upgradeURL>https://ap5.salesforce.com/secur/weakhttps.jsp?l=1</sf:upgradeURL>
               <sf:upgradeMessage>Stronger security is required</sf:upgradeMessage>
            </sf:UnexpectedErrorFault>
         </detail>
      </soapenv:Fault>
   </soapenv:Body>
</soapenv:Envelope>

I am using Username and password+security token.

enter image description here

5

Since you are connecting to Salesforce from SOAP UI, so this SOAP UI must be TLSv1.1 or above.

Reach to SoapUI-5.2.1 VMOPTIONS file which is under SmartBear\SoapUI-5.2.1\bin

SOAP UI PATH

Add entry like this:

-Dsoapui.https.protocols=SSLv3,TLSv1.1

This is a sample entries in that file:

-XX:MinHeapFreeRatio=20
-XX:MaxHeapFreeRatio=40
-Xms128m
-Xmx1000m
-Dsoapui.properties=soapui.properties
-Dsoapui.home=C:\Program Files\SmartBear\SoapUI-5.2.1/bin
-Dsoapui.ext.libraries=C:\Program Files\SmartBear\SoapUI-5.2.1/bin/ext
-Dsoapui.ext.listeners=C:\Program Files\SmartBear\SoapUI-5.2.1/bin/listeners
-Dsoapui.ext.actions=C:\Program Files\SmartBear\SoapUI-5.2.1/bin/actions
-Dsoapui.https.protocols=SSLv3,TLSv1.1
-Dwsi.dir=C:\Program Files\SmartBear\SoapUI-5.2.1/wsi-test-tools
-Djava.library.path=C:\Program Files\SmartBear\SoapUI-5.2.1/bin
-Djava.util.Arrays.useLegacyMergeSort=true
-splash:SoapUI-Spashscreen.png
  • 2
    cool, Works for me !! Thanks you. Just need to restart the SOAP UI post -Dsoapui.https.protocols=SSLv3,TLSv1.1 changes – user4567570 May 23 '17 at 17:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.