In my company we use Servicemax managed package. In one of the transactions, we have a visualforce template that generates a report.

When I check it in our visualforce page I see it like this:

HLS Mobile Final Service Report - JapaneseV2

But when users generate the report, it shows like this:

Final Quotation Report

I tried to install the font HanaMinA.ttf in my computer. I tried to create a txt file with japanese characters on my windows desktop. I also tried to change encoding for the testing user. None of that worked.

How can I fix this issue?

  • never had to do this so these are guesses but I wonder if a the encoding on the page needs set <meta http-equiv="Content-Type" content="text/html;charset=UTF-8" /> or b) you can add font-family css into the PDF page to see if that works...
    – n34_panda
    May 23, 2017 at 16:10

1 Answer 1


There are two things would apply here.

  1. From Fonts Available When Using Visualforce PDF Rendering:

    Arial Unicode MS, Helvetica, Times and Courier.

    These rules apply to server-side PDF rendering. There are no other fonts you can use that will reliably render as PDFs within Salesforce. What you can view on a monitor is an entirely different story.

  2. From Visualforce PDF Rendering Considerations and Limitations:

    “Arial Unicode MS” is the only font supported for extended character sets that include multibyte characters.

If you can't render it with Arial Unicode MS, you're out of luck. You'll want to change the font in your original layout to support Arial Unicode MS to test it first. If it does, then you could specify it as an alternative in your CSS.

Not the answer you're looking for? Browse other questions tagged .