1

We're running into a funky error with a login flow, where users logging in to our Community see a weird prompt/error page before they can log in.

We've had the login flow for a long time and haven't intentionally changed anything about it, so I suspect there's a change in seemingly-unrelated items referenced in the flow which are causing an issue. This question is not about how to solve the problem (although if you have ideas, check out this related question!)

In trying to resolve this, we realized it would be really helpful to look at debug logs for this transaction, where (with the right Log Levels set) we could see what's going on inside the flows. But can't figure out how to make them show up:

  • Capturing debug logs for the Site Guest User (the context pre-login) doesn't capture any logs.
  • Capturing debug logs for the user who is logging in (the context post-login) doesn't capture any logs.

How can I capture and examine logs from Login Flows?

Here's an example of the error message:

enter image description here

1

Have you tried setting debug log for the user who is facing error in login. I am sure, there would be class invoked in login flow (if using the login flow provided on SF blog) and you can capture fault events there in logs.

  • Thanks for the idea. As I wrote in the original question: Capturing debug logs for the user who is logging in (the context post-login) doesn't generate any logs. – Benj May 26 '17 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.