1

I'm trying to integrate the JBASDK for android in android studio following this guide: http://salesforce-marketingcloud.github.io/JB4A-SDK-Android/sdk-implementation/implement-sdk-google.html

but when I include the dependency I get the following error message:

Failed to resolve: com.salesforce.marketingcloud:marketingcloudsdk:4.9.2

I've tried common solution, I've added maven, I've tried different internet connections, I'm not behind a proxy and other dependencies work great.

1

Apologies. We have a documentation bug and I have opened an internal ticket for its immediate remediation.

The dependency line should read for v4.x versions of the SDK:

  com.exacttarget.etpushsdk:etsdk:4.9.2

UPDATE

The com.salesforce.marketingcloud:marketingcloudsdk:5.+ is accurate for v5.x artifacts as of 20180104.

com.exacttarget.etpushsdk:etsdk:4.+ is accurate for all v4.x artifacts.

  • just saw your answer, should the documentation be updated here as well ? salesforce-marketingcloud.github.io/JB4A-SDK-Android-v4.5.0/… – angryITguy Jan 4 '18 at 8:45
  • 1
    It actually should not. As of v5.x we have rebranded the SDK to match corporate guidelines and com.salesforce... is accurate for all versions 5.x and later. The link you provided is for a 4.x artifact and points to com.exacttarget... – Bill Mote Jan 4 '18 at 14:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.