I know you can edit records (including Work orders) in Salesforce1 but when i am trialling Field Service I cannot edit a Work order.

My user is now set to the System Administrator profile so I can't believe their are missing permissions.

The documentation states with the app you:

The mobile solution provides access to critical information regardless of connectivity, and uses automated processes to support a full range of fi eld activities, from sending and receiving real-time job updates to managing work orders and speeding up manual administrative work. It even enables users to generate reports, access knowledge articles, update parts required, and capture a customer’s signature.

It states "managing work orders" as a feature but I can only see features for creating a service report, a new task, opening in salesforce1, adding to the feed and getting directions.




There are a few ways, the simplest being:

  1. In setup go to "field service mobile settings"
  2. Select "Show Edit Full Record"

The other options are to use Quick Actions, for example: empowering users with quick actions

| improve this answer | |
  • Thanks, it's so obvious - I must have looked at that page a few times. I think we will aim to use quick actions for better control but until then the edit full record mode is useful. Thanks. – sfdc_beginner1 May 20 '17 at 17:17
  • thanks! this has helped. – vilelam Apr 3 at 20:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.