0

Whenever I refresh the metadata index for the 'CustomObject' Metadata type, an incorrect set of objects comes up. For example, I have a custom object named Account Address, which tracks the addresses of accounts. When I refresh, mavensmate does not see the Account Address object under the CustomObject folder.

enter image description here

I tried to edit the package.xml manually to contain a * in a member field inside of CustomObject, but MavensMate only reverts the file back to the previous state.

How do I use MavensMate to download all CustomObject metadata?

1

It is very important to make sure that you don't have the 'Ignore managed metadata' box checked. This box is found under MavensMate's settings icon.

Once you have unchecked it, make sure to refresh your metadata index.

enter image description here

0

Instead of putting a star (*) in the package.xml, can you try and put the actual sObject API name and see if that works?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.