0

my Flow tells me that I have one or more screens and thereforce can't autolaunch which is weird becauase I only used Fast Lookup (gets a test record to work with), Record lookup, Loop, Decision, Assignment, and Record Create.

The process works perfectly when launched via "Run" (it takes it's input from the test record) but now it's time to start it from Process Builder the autolaunch is greyed out due to above reason. Specific message: Requires user interaction because it has one or more screens.

How can I find out which action has fooled this Flow in to thinking it can't be autolaunched, and is it possible to undo this so I don't have to rebuild the workflow?

Cheers!

  • Where are you getting this error? When viewing / editing the flow properties? Try saving a new version, i think that'll do it. – gorav May 12 '17 at 13:31
  • This worked perfectly. Thanks very much! I don't think I can mark a comment and an answer - if you like to update I can mark as correct. – Ashley Evans May 15 '17 at 20:11
  • great glad it worked for you. the fact that flow works at all is amazing sometimes :) – gorav May 16 '17 at 2:01
  • haha - yeah, I come from SharePoint and Workflow world where we have the same feeling :) – Ashley Evans May 17 '17 at 7:49
0

Once a flow has been saved as a 'regular' flow, you need to save a new version to set it as auto-launched.

I've found this can happen even if you have not activated the flow yet. Not sure if its documented or not!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.