1

I'm working on an integration that creates Leads through the REST API. One of the fields that is updated on create is a date/time and so far every time we send a Lead through the time in this field is adjusted 4 hours back from the time sent through.

Our org setting for timezone is GMT -4:00 so I think Salesforce is seeing the time as GMT and then converting it to our local setting.

Is there some part of the POST request that should be changed that we are missing or is there a setting in Salesforce we don't have right?

  • 1
    can you post you code whatever you have tried so far. – Santanu Boral May 11 '17 at 18:38
  • Hi ZackB, welcome to SFSE. Please take a moment to visit the help center, scroll through the tour, and read How to Ask. Without seeing the payload in your POST request, it is very difficult to offer assistance. Please edit your post to clarify what you have tried in this regard. Thanks! – Adrian Larson May 11 '17 at 18:43
  • 1
    can you post the request payload you are sending – Ashwani May 11 '17 at 19:08
0

My apologies for not posting code, I was waiting on info from someone else. I think this was a problem with a missing 'Z' on the date time in the POST. Per this article https://help.salesforce.com/articleView?id=Data-Loader-Import-data-for-Date-or-Date-Time-field-1327108684799&language=en_US&type=1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.