• I released a Managed Package version 1.1 and installed on both Developer Org D1 and Sandbox Org S1.
  • Later I added a new Lightning Component and Lightning Record Page to the Package and released a Major version 1.2.
  • I am able to upgrade D1 to 1.2 (and many other developer orgs).
  • But when I tried upgrading S1 from 1.1 to 1.2 it throwed me an error as below and installation failed:

(Customer_Object_Record_Page) Validation Errors While Saving Record(s), Details: There were custom validation error(s) encountered while saving the affected record(s). The first validation error encountered was "We couldn't retrieve the design time component information for component nmspc:AnotherLightningPage.".

I am not able to understand the message "We couldn't retrieve the design time component information for component X" and what is so different from Developer Org to Sandbox Org.

Note: All Lightning pages have access="global"

  • 2
    My guess is that your Sandbox is on Summer '17. It may be a bug...
    – sfdcfox
    May 8, 2017 at 23:04
  • @sfdcfox exactly, it is on Summer '17 and it is our customer's Org. Is there any work around for this ? May 8, 2017 at 23:18
  • 1
    Log a case with partner support. It's not something we can likely assist you with.
    – sfdcfox
    May 8, 2017 at 23:36
  • @sfdcfox Just an update, I signed up for a Summer 17 preview release and tried installing there. Installation went smooth without the above error. Can there be any specific deployment validations configured per org ? May 9, 2017 at 22:11
  • Sorry, I haven't seen this error, and I don't have a way to easily replicate it. I was hoping it'd be something simple. Still, I hope you get an answer to this, it'd be great to know what happened.
    – sfdcfox
    May 9, 2017 at 22:27

3 Answers 3


If anyone else gets later on 2019+ it could also indicate that the page that calls a component is not in the target org. The fix is to just add that to your package.

Just ran into that today.

  • Just ran into that today - yup. refactoring my sfdx-project into multiple sub-layers and needed to move my lwc folder from it's old place into a different layer
    – bkwdesign
    Feb 15, 2021 at 17:31

This is accepted as known issue by Salesforce and patch fix is scheduled for all the instances as listed here. As mentioned by sfdcfox the issue is specific to Summer 17 (Sandbox Org) and not happening on Spring 17 (Developer Org).

  • We had the same issue in Spring '17 already - and id be interested to know if the fix needs to be applied to the target org or to the packaging org. Not all orgs have the fixed rolled out so far. Jun 7, 2017 at 11:34
  • Also, we noticed that installation via upgrade API works whereas installation via UI fails with the error above Jun 7, 2017 at 18:01
  • We still see this issue intermittently with certain orgs - what can we do? Sep 7, 2017 at 12:45

It happens to me that I inserted LWC metadata in AURA metadata on package to deploy and this error was throw. Ex:

This is how I write:

<types> <members>MyLWC</members> <name>AuraDefinitionBundle></name> </types>

This was the correction:

<types> <members>MyLWC</members> <name>LightningComponentBundle></name> </types>

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .