1

I am setting up journey builder for welcome series email based on custom Salesforce date field, one its gets time stamped the email should be sent to subscribers

Event Used - Salesforce Data Event

Added this particular event in the journey below

Welcome email

I am getting these errors:

Error occurred during triggeredsend publish and activation. The EventSchema could not be found. Additional info: {"errorMessage": "TheEventSchema could not be found."}

Flow Creation failed. INVALID_TYPE: sObject type 'ApexClass' is not supported.

Why am I getting these errors? How can I fix them?

1

I ran into this same error and we figured out the cause and the solution. The issue is that execution of a journey on a Salesforce entry event creates a "triggered send" in Salesforce. The triggered send is actually writing APEX code for the trigger. That means that your integration user needs the "Author Apex" permission. That setting also comes with "View Setup" and "modify All data" so take that into consideration. Also, you need to make sure in the Marketing Cloud Connector configuration in Salesforce you set the right permission to execute a triggered send-it's either Sys Admin or All Users - and then enable the triggered sends on the object that you will be using as your entry events. We followed these steps and the error went away - without having to grant Sys Admin to our integration user.

0

Got Update from Support: Marketing faceless ID User is restricted to all the objects in salesforce due to profile that he is assigned to.

So, Instead of using marketing profile in Salesforce for Marketing faceless ID user, give System admin permissions so that it can access all the objects that we are trying to use in Journey builder

  • Did they share the specific permissions needed, or did they just ask you to change to sys admin profile? :) Have a similar case where we are using custom profile, and have given all the permissions the documentation indicates - although this isn't enough. – Kenneth Wagner May 9 '17 at 8:45
  • The profile has to access all the custom objects as well as other additional permissions to properly get the data from salesforce – Autodidact May 9 '17 at 11:09
  • As Said, we tried those and didn't work - still have an open case :) the data sync worked, but not the journey activation - quite Strange and support doesn't know yet :) – Kenneth Wagner May 9 '17 at 11:13
  • Just checking, So you gave system administrator profile and for sys admin profile did you add all marketing cloud related permissions?? I forgot to add this so I wanted to cross check with you – Autodidact May 9 '17 at 11:16
  • All MC related permission from documentation to a custom profile as we cannot use sys Admin due to compliance :) – Kenneth Wagner May 9 '17 at 11:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.