I have a Support Representative Profile and in that Profile I have two users (User1 and User2). I have enabled "Knowledge User" for both and also given the following permissions to Support Representative profile.

Manage Knowledge Article Import/Export   
Manage Articles  
Manage Salesforce Knowledge  
Allow View Knowledge     
Knowledge One   

when I login as User1, But can see the Knowledge tab and Article Management tab. But when I login as User2, I don't see the Knowledge tab and Article Management tab why ??

enter image description here

Here you go enter image description here

  • The only possible reason I could think of is the "Knowledge User" checkbox, but you mentioned that it's already checked. I would recommend to verify that again. What is the license type of this profile? May 3 '17 at 4:08
  • Please see the updates above. Its really frustrating to see this weird behavior ! Each Setting I have check May 3 '17 at 4:13
  • help.salesforce.com/articleView?id=000005402&type=1 -> You pretty much have covered all the permissions required for setting up knowledge article. Try to setup a new user with the same profile and enable knowledge user, check if he sees the article tab ? May 3 '17 at 4:25
  • Hey What if the new user can see the tabs? I wonder then why existing user which is created in that profile cant' see, if one can see that without any issue? Both should faced the problem May 3 '17 at 4:27
  • do both the users are using same license? check the user's customize my tabs, clicking on that button. Also try to create a new App like Knowledge Management and expose those tabs. Assign the App in the profile. Secondly, are you using the knowledge in classic or console mode? May 3 '17 at 4:38

I got the solution to the above issue. Each user has to do the Customize Tab setting and in that tab setting you need to make the fields visible.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.